ThWboard Support-Forum (Archiv)

Ort: / Boardübersicht / English support board / Error in sql installing thwb

Seite 1 von 1

tomerqueves schrieb am 14.12.2006 um 00:00 Uhr

Hi, Im try to install THWB in my localhost. During the install the install wizard report me an error...


Query execution error: INSERT INTO tb_board (boardid, boardname, boardlastpost, boardthreads, boardposts, boarddescription, categoryid, boardorder, styleid, boardlastpostby, boardthreadtopic, boardthreadid, boarddisabled) VALUES ( '', 'Board #1', '0', '0', '0', 'Beschreibung von Board #1', '1', '1', '0', '', '', '0', '0' )

MySQL said: Out of range value adjusted for column 'boardid' at row 1

Itīs posibe that there was a problem with boardid field.
Going into phpmyadmin a msg can be read....

It sayd that primary key an index("Indice") canīt be selected together for(to?) boardid field.

Itīs posible helpme. I do not used the search tool because I speaks spanish and donīt know which is the correctly buton for it. Hope to help me and sorry if my inglish is not very clear.

Thank you very much.
I will wait for an answer.

: D

Narodnaja schrieb am 14.12.2006 um 12:52 Uhr

Hello Tomerqueves,

I think the problem results of an empty value for the boardid in your sql query (see "... boarddisabled) VALUES ('', 'Board #1 ...").
Usually, you should find a value '1' in this field. ("... VALUES ('1', 'Board #1', ...)

I have no idea how this should result when you use the insallation wizard... which system do you have installed on your localhost ? (PHP version, MySQL version, operating system, etc.)

A little strange.

By the way: Your english is clearer than many german posts in here ;)

tomerqueves schrieb am 14.12.2006 um 16:25 Uhr

ok, thank you very much. Problem was solved. It was this narod naja.
I had to go into install_funtioncs.php and correct some values that was generating trouble. There was a field that was index and primary key and a field is index when is primary key. This line have been convert to coment and this was solved. Then a list of values were such this '' and have not some value. I have been changint these by '0' and finally i was into table to user datas and there wera some fields that were not null and i changed to null because system was requiring an default value.

Now im trying to run the system ī
Thank you very much.

tomerqueves schrieb am 14.12.2006 um 16:32 Uhr

canīt see errors now. board is working but i was installing a chess system and this is a forum.
Itīs no problem. Now there are more languajes that i cant underestan... said adding German languaje.
mmm how is said.. Merry cristmas

Seite 1 von 1